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INTRODUCTION 
 
These notes and exercises are aimed at those who want to expand their 
knowledge of Excel 2007. 
 
 
Knowledge assumed  
 Excellent working knowledge of Excel and/or 

attendance on the Spreadsheet Intermediate course 
an understanding of using formulas and functions 

  
  
 
 
Areas covered  
 using advanced filters 
 protecting worksheets and workbooks 
 creating pivot tables 
 introduction to macros 
 useful functions for serious Excel users 
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Document signposts 
 
 
 
Instructions for you to type  
 Bold text 

 
 
 
Shortcuts  
 

 
 
Reminders  
  

 
 

 
 
Notes  
  
 
 
 
 
Exercises  
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FORMATTING DATA 
 
Excel contains many standard formatting options, but there may be times when 
the formatting that you need to apply is not a ready-made option.  On these 
occasions, you can create a custom format. 
 
CUSTOM FORMATS 
 

 Open the Courses workbook from the ExcelAdvanced folder on drive C 

 Make each column wide enough so that all the data is visible 

 
 
 
Formatting a number 
 
The sequence numbers in column A are all five digit numbers.  Your company 
wants the numbers to be displayed in the format: 12-789 
 
This is not one of Excel’s built-in formats, so you will need to create a custom 
format to display the numbers in this form. 
 
Formatting codes are used to create formats.  These codes force Excel to make 
your data appear how you would like.  The following table lists some of the 
codes that you can use to format numerical values. 
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Code Description Examples 
Format Value Display 

. 
(period) 

This placeholder displays a 
decimal point in a number. 

   

# Digit placeholder.  This code 
does not display extra zeros 
when the number that you type 
has fewer digits on either side 
of the decimal point than there 
are # symbols. 

###.## 3.5 
29.568 

3.5 
29.57 

0 (zero) Digit placeholder.  This code 
pads the value with zeros when 
the number has fewer digits on 
either side of the decimal point 
than there are zero 
placeholders. 

##0.00 3.5 
29.568 

.6 

3.50 
29.57 
0.60 

? Digit placeholder.  This code 
leaves a space for insignificant 
zeros but does not display 
them. 

???.?? 3.5 
29.568 

3.50 
29.57 

 

/ Displays a number as a fraction. # ??/?? 3.5 3 ½  
, The comma is used as a 

thousands separator.  It is also 
used to format a number as 
though it were divided by a 
thousand or a million. 

##,### 
 
##, 
 
 
##,, 

55555 
 

5000 
55555 

 
5000000 

55,555 
 

5 
56 

 
5 

( ) Formats negative numbers. (##,###) -55659 (55,659) 
- Places a hyphen in a number. 00-000 12345 12-345 
“ ” Specifies the use of a text 

string. 
£### “ per 
Kilo” 
 
##,, “ m” 

3 
 
 

5000000 

£3 per 
Kilo 
 

5 m 
 
 
To display the sequence numbers in the format 12-345: 
 

 Select the range A2:A27 

 Click the dialog box launcher for the Number group on the Home tab 

 
  

Dialog box launcher 
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The Format Cells dialog box is displayed. 
 
From the Category list choose: 
 

 Custom 

A list of custom format types is displayed.  This includes any formats that you 
have previously customised.  You need to choose a type from the list as the 
starting point for your new format. 
 
From the list of types choose: 
 

 0 

In the Type box: 
 

 Enter 00-000 

 
 

 Click OK 

The sequence numbers are displayed in the new format. 
 

 

Type box 
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Formatting a date 
 
Date format codes include: 
 
Code Description Examples 

Format Value Display 
m Displays the month as ## m 25/12/2008 

7/4/1998 
12 
4 

mm Displays the month as 00 mm 7/4/1998 04 
mmm Displays the month 

abbreviated to three letters 
mmm 25/12/2008 Dec 

mmmm Displays the name of the 
month in full 

mmmm 7/4/1998 April 

d Displays the day as ## d 25/12/2008 
7/4/1998 

25 
7 

dd Displays the day as 00 dd 7/4/1998 07 
ddd Displays the name of the day 

abbreviated to three letters 
ddd 25/12/2008 Thu 

dddd Displays the name of the day 
in full 

dddd 7/4/1998 Tuesday 

yy Displays the year as 00 dd/mm/yy 7/4/1998 07/04/98 
yyyy Displays the year as 0000 mmm-yyyy 25/12/2008 Dec-2008 
 
You are going to format the dates in column B so that the names of the months 
are shown in full. 
 

 Select B2:B27 

 Click the dialog box launcher for the Number group of commands 

 Ensure that the Custom category is selected 

 Select the Custom Type dd-mmm-yy 

 Add an extra m to the month part of the format, producing dd-mmmm-yy 

 Click OK 

The months are now shown in full. 
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General formatting codes 
 
Code Description Examples 

Format Value Display 
General The default general 

format. 
General 26.347 

Text 
26.347 

Text 
£ - + / ( ) : 
space 

These characters are 
displayed in the number. 
To display other 
characters, enclose the 
character in quotation 
marks or precede it with a 
backslash. 

   

\character This displays the character 
you specify. 

##,, \m 12345678 12 m 

@ Text placeholder.    
* This repeats the next 

character in the format to 
fill the column width. 

General *. 
 
@ *. 

1.23 
 
Text 

1.23 ...... 
 
Text ...... 

_ 
(underscore) 

This skips the width of the 
next character.  It is 
commonly used as “_)” to 
leave space for a closing 
parenthesis in a positive 
number format when the 
negative number format 
includes parentheses.  This 
allows the values to line up 
at the decimal point. 

See page 12 

[Black] Specifies the colour Black 
for the format. 
(Can also use [Green], 
[White], [Blue], [Magenta], 
[Yellow], [Cyan], and 
[Red]) 
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 Open the UsedCars workbook from the ExcelAdvanced folder on drive C 

 Format the range A5:A10 so that the number xxx is displayed as 01-0xxx. 
For example, 251 must be displayed as 01-0251 

 
 

 Format the dates in E5:E10 to display in the format November 2009 

 
 

 Format the date in A2 to display as July 21, 2009 (Tuesday) 

 Format the values in H5:H10 to display with the decimal points vertically 
aligned (without adding zeros to any of the numbers) 
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 The engine capacity values are given in cubic centimetres. Format F5:F10 to 
display the units cc after each value 

 
 

 Change the format of the range F5:F10 to display as litres to one decimal 
place, so 4200 cc is to be displayed as 4.2 L and 750 cc as 0.8 L 

 
 

 On the Petrol worksheet, format B6:B8 so that the decimal points are 
vertically aligned and the character p is added at the end to indicate that the 
price is in pence 

 Format A6:A8 to fill the column width with full stops after the text values 

 
 

 Save and close the UsedCars workbook 
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Separate codes for positive and negative numbers 
 
The custom format of a cell can have up to four sections of code, separated by 
semicolons.  These code sections define the format for positive numbers, 
negative numbers, zero values, and text, in that order. 
 
<positive>;<negative>;<zero>;<text> 
 

 Open the Sales workbook from the ExcelAdvanced folder on drive C 

 Select row 19 

 Format the row with the Custom Format: 
[Blue]£#,##0;[Red](£#,##0);0.00;“Sales ”@ 

 
 
Observe that the positive values are formatted using the first part of the code; 
the negative value is formatted according to the second part; the zero value 
according to the third part; and the text was formatted using the fourth part of 
the code. 
 
 

[Blue]£#,##0;[Red](£#,##0);0.00;“Sales ”@ 
 
 
 
With row 19 selected 
  

 Change the third part of the custom format from 0.00 to “Zero” 
[Blue]£#,##0;[Red](£#,##0);“Zero”;“Sales ”@ 

The display for the zero value is changed. 
 

 
 

 Change the value in E4 to 635 

E19 now becomes a positive value and is formatted like the other positive 
profits. 
 

 
 
You do not have to include all code sections in your custom formats.  If you 
specify only two code sections, the first section is used for positive numbers and 
zeros, and the second section is used for negative numbers.  If you specify only 
one code section, it is used for all numbers. 
 

 Select the Summary worksheet 

Format if positive 

Format if negative 

Format if zero 

Format if text 
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You will format the profit as sterling to two decimal places, with negative values 
shown in parentheses and formatted red. 
 

 Select B5:B10 

 Display the Custom Format list 

The format that you need is not in the list. 
 

 Select a format type that is close to the format needed; I chose 
£#,##0.00;[Red]-£#,##0.00 

 
 

 Edit the format to: £#,##0.00;[Red](£#,##0.00) 

 Click OK 
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The zero value is formatted the same as the positive values.  Observe that the 
decimal points on the negative values are not aligned with those of the positive 
values. 
 
To align the decimal points you need to change the code for the positive values, 
ensuring that space equivalent to a closing parenthesis is inserted to the right of 
the number.  The code “_)” must therefore be added (see page 7). 
 

 Ensure that B5:B10 is still selected 

 Display the Custom Format list 

 Edit the format to: £#,##0.00_);[Red](£#,##0.00) 

 Click OK 

 
 

 Save and close the Sales workbook 
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SORTING DATA 
 
As your worksheet grows larger, it is useful to remember that you can sort it at 
any time. 
 
SINGLE LEVEL SORT 
 

 Ensure that the Courses workbook is open 

 Select any cell in the column containing the Course Name 

 Click the Sort & Filter button in the Editing group on the Home tab 

 Select Sort A to Z 

The data is sorted by Course Name in ascending alphabetical order. 
 

 Click Undo 

 
MULTI LEVEL SORT 
 
Next you will create a two level sort to sort the data by Venue, and for each 
Venue, sort by Course Name. 
 

 Select any cell that contains data in the worksheet 

 Click the Sort & Filter button in the Editing group on the Home tab 

 Select Custom Sort 

The Sort dialog box is displayed. 
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 Ensure that the My data has headers check box is ticked 

 Click the Options button 

The Sort Options dialog box enables you to refine the way the sort is executed. 
 
For example, if the data was entered so that the headings were in rows not 
columns, you would choose to sort left to right instead of top to bottom. 
 

 
 

 Click Cancel to close the Sort Options dialog box 

From the drop-down list in the Sort by box choose: 
 

 Venue  

You want to sort the values in ascending order (A to Z), so leave the other two 
boxes in the row unchanged. 
 

 Click the Add Level button 

From the drop-down list in the Then by box choose: 
 

 Course Name 

 
 

 Click OK 
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The sort is completed. 
 

 
 

 Sort the data by Course Name in ascending alphabetical order in preparation 
for the next section 
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SUBTOTALS 
 
For this exercise you will add subtotals to the worksheet that calculate the 
income from each course. 
 

 Ensure that the data is sorted by Course Name 

 Select any cell that contains data in the worksheet 

 Click Subtotal in the Outline group of commands on the Data tab 

The Subtotal dialog box is displayed. 
 

 
 
You want the totals to be added to the page when the Course Name changes. 
 

 In the At each change in: box click the down arrow and select Course Name 
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 Click the down arrow in the Use function: box to see the list of possible 
functions 

You want the subtotal to display the sum for each of the different course names. 
 

 Ensure that Sum is selected 

You want the subtotal to appear in the Total column. 
 

 Scroll through the list in the Add subtotal to: box and ensure that there is a 
tick against Total but that no other items are ticked 

 Click OK 

Subtotals are added to the worksheet. 
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PRINTING SUBTOTALS 
 
You can print data relating to each subtotal on a separate page. 
 

 Click the Subtotal button on the Data tab 

In the Subtotal dialog box: 
 

 Select the Page break between groups option 

 
 

 Click OK 

Broken lines are inserted in the worksheet to show the page break positions. 
 

 Display the Subtotal dialog box 

 Remove the tick from the Page break between groups option 

 Click OK 

Here 
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GROUPING AND OUTLINES 
 
When you add subtotals to a worksheet, you ‘group’ rows that hold information 
on the same data together.  Now that these rows are grouped, you can use the 
Outlining feature to display selected information. 
 
Notice that outline controls are displayed to the left of the worksheet.  These 
enable you to view different levels of the outline.  By using the outline you can 
quickly hide levels of detail leaving summaries of section headings showing on 
the worksheet. 
 
At each subtotal row there is a minus (-) sign in the outline pane. 
 

 Click the minus sign on the Email Total row 

The Email group collapses and only the subtotal is displayed. 
 

 
 

 Click the plus (+) sign on the Email Total row to expand the group 

At the top of the outline pane there are three outline buttons labelled 1, 2, and 
3.  These correspond to the three levels of detail that can now be easily 
displayed. 
 
 
 

 
 

 Click the Outline button numbered 2 

  

Outline buttons 
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This displays the level 2 outline, with all the groups collapsed showing only the 
subtotals. 
 

 
 

 Click the Outline button numbered 1 

The level 1 outline displays only the Grand Total. 
 

 
 

 Click the Outline button numbered 3 to expand all the groups 

 
 
 
To remove the subtotals: 
 

 Display the Subtotal dialog box 

 Click the Remove All button 

The subtotals and outline controls are removed. 
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The Grouping and Outlining feature can be used on any worksheet that contains 
formulae. 
 

 Ensure that any cell containing data is selected 

 Ensure that the Data tab is selected 

 Click the Group down arrow in the Outline group of commands 

 
 

 Select Auto Outline 

Outline controls are displayed above the worksheet. 
 

 
 
As with the subtotals, you can click on the minus signs to collapse the display 
and then click on the subsequent plus signs to expand the display, or you can 
click on the numbered buttons 1, 2 or 3 to display the corresponding outline 
level. 
 

 Click the Outline button numbered 2 

Columns F and G that were used to calculate the Cost per course are both 
hidden. 
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 Click the Outline button numbered 1 

All the columns used to calculate the total cost are now hidden. 
 

 
 
To clear the outline from the worksheet: 
 

 Click the Ungroup down arrow in the Outline group of commands 

 
 

 Select Clear Outline 
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FILTERING DATA 
 
When working with large amounts of information, you will find it useful to use a 
filter to see only relevant records. 
 
For example, you may want to see only those courses offered at a particular 
venue, or courses over a certain price, or those that are offered over a specified 
number of days.  These criteria can be used in isolation or in combination. 
 
The filtered data can be printed, providing a quick way to produce reports based 
on a portion of the data.  Data that has been filtered can also be used to 
produce charts, but see the notes on pages 26 and 27. 
 

 Sort the data by Sequence number in ascending order 

 
THE AUTOFILTER TOOL 
 

 Ensure that the selected cell is within the data 

 Click the Filter button in the Sort & Filter group on the Data tab 

This can also be achieved on the Home tab by clicking the Sort & Filter button 
in the Editing group and then choosing Filter. 

 
A drop arrow is added to each column heading. 
 

 
 

 Click the drop arrow in the Course Name column 
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All the course names are listed in the bottom pane and all are ticked, indicating 
that they all are being displayed. 
 
To display the information for one course only, you will need to ensure that the 
course you want to be displayed is the only one ticked. 
 
To display only the data for the Windows NT course: 
 

 Click (Select All) to remove the ticks from all the course names 

 Click Windows NT 

 Click OK 

Only the rows containing the Windows NT course name are displayed; all the 
other courses are hidden. 
 

 
 
To display all the records again: 
 

 Click the Clear button in the Sort & Filter group on the Data tab 

Alternatively, you can click the drop arrow in the Course Name column, choose 
(Select All), and click OK. 

 
 

 Use the filter to display only the courses in Leics 
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Custom Filter 
 
Now that you have filtered the Leics courses you will customise the selection to 
show only those courses that have a total cost of more than £73.50 (excluding 
VAT). 
 

 Click the drop arrow in the Cost per course column 

 Point to Number Filters 

 
 

 Select Greater Than… 

The Custom AutoFilter dialog box is displayed. 
 

 
 
The condition is that the Cost per course must be greater than £73.50. 
 

 In the value box, type 73.5 

 Click OK 

Type value here 
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The Intro Access course listed in row 10 will be reduced to 2 sessions. 
 

 Change the value in F10 to 2 

Now that the cost has changed you need to reapply the filter. 
 

 Click Reapply in the Sort & Filter group on the Data tab 

The filter is reapplied and now excludes the Intro Access course. 
 

 Display all the records again 

To turn off Autofilter: 
 

 Click the Filter button in the Sort & Filter group 

 

Be aware that if you use filtered data to produce a chart, when the filter is 
removed from the list, the chart updates to include the hidden data. 

 
  



Excel Advanced (021209) 27 ©De Montfort University, IT Training 2009 
 

ADVANCED FILTER 
 
The Advanced Filter allows you to filter records in situ or copy the filtered 
records to another sheet within the workbook.  You will look at both of these 
methods. 
 
Data that is copied to a different location can be used independently of the 
original worksheet. 
 

A chart based on data copied to a different worksheet will not change. 

 
To use the Advanced Filter you must first create a criteria range.  This is a cell 
range that contains a copy of the data headings and is used to enter the filter 
specifications. 
 
 
Showing the filtered data within the same sheet 
 
For this exercise you will select courses that run over two sessions. 
 
To create the criteria range: 
 

 Copy the data headings from A1:J1 to L1:U1 

Tip 
 
To also copy the size of the columns when copying data: 
Immediately after the paste operation; 

•  Click the Paste Options button   
    (the Paste Options button appears on the bottom right of the pasted range) 
•  Select Keep Source Column Widths 
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 For the criteria, type 2 into cell Q2 (this should be ‘No Sessions’ and will 
filter courses that run over 2 sessions) 

The cell range L1:U2 is now your criteria range. 
 

 Select any cell within the data that is to be filtered (this enables Excel to 
determine the range of cells to use for the filter operation) 

 Click Advanced in the Sort & Filter group on the Data tab 

The Advanced Filter dialog box is displayed showing the range of cells 
containing the data in the List range box (A1:J27). 
 

 
 

 Ensure that the radio button: Filter the list, in-place is selected 

 Click the Collapse Dialog button in the Criteria range box and select L1:U2 

 Click the Collapse Dialog button again to display the dialog box 

 
 

 Click OK and the filter is applied to the data 

 Look at the list of data to see that the filter has worked 

  

Collapse Dialog 
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To show all the records again: 
 

 Click Clear in the Sort & Filter group 

If you add two criteria in separate columns on the same row in the criteria 
range, Excel will filter records satisfying both criteria.  This is an AND condition. 
 
If you use two criteria on separate rows, Excel will filter records that match 
either criterion.  This is an OR condition. 
 

 Create an Advanced Filter for courses that run over two sessions and take 
place at Bedford.  (Don’t forget that this is shown as Bed in the data.) 

 Show all the data again 

 Create an Advanced Filter to display courses that run over two sessions or 
take place at Bedford.  (Don’t forget to increase the criteria range to include 
all the criteria rows.) 

 Show all the data again 

 
Using a filter to extract data to another sheet 
 
In this exercise you will filter the data to display the courses taking place in 
Leicester that run for one session only, and put this data on Sheet2. 
 
You will first edit the criteria range with these criteria. 
 

 Type Leics into cell P2 (criterion for the Venue) 

 Type 1 into cell Q2 (criterion for the number of sessions) 

 Ensure that no other criteria are present in the criteria range 

 Select Sheet2 (this is because you need to select the sheet where you want 
to display the filtered results before starting the Advanced Filter process) 

 Click Advanced in the Sort & Filter group on the Data tab 

 In the List range box, click the Collapse Dialog button 

 Select Sheet1 

 Select the range A1:J27 

 Click the Expand Dialog button 
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 In the Criteria range box, click the Collapse Dialog button 

 On Sheet1 select the range L1:U2 

 Click the Expand Dialog button 

 Select the Copy to another location radio button 

 Using the Copy to box, choose to copy the data into cell A2 

 
 

 Click OK 

 Check that the filter has worked 

 Close the workbook without saving 
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DATA MANAGEMENT 
 
For this exercise you will use a workbook which details the working hours of the 
staff of the Jumble Sales Corporation.  It contains several worksheets, some of 
which you will be using in the following exercises. 
 
You have been asked to calculate bonus payments to staff who have worked for 
the company for 25 years or more (as at 1 January 2010). 
 

 Open the workbook named JumbleSalesPay 

 Insert a new worksheet and rename it Bonus Payments 

The current workbook contains salary details.  The information relating to how 
long an employee has worked for the company is stored in the JumbleSalesStaff 
workbook.  You will use a Microsoft Query to filter out the data you need from 
JumbleSalesStaff and copy it into the current workbook. 
 
USING MICROSOFT QUERY 
 
Microsoft Query is used to request filtered information from an external source. 
 

 Ensure that cell A1 on the Bonus Payments worksheet is selected 

 Click From Other Sources in the Get External Data group on the Data tab 

 
 

 Select From Microsoft Query 
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The Choose Data Source dialog box is displayed, listing the types of files you can 
use for your query. 
 

 The data that you need is in an Excel workbook, so choose Excel Files from 
the list 

 
 

 Click OK 

The Select Workbook dialog box is displayed, together with a Connecting to data 
source… message. 
 

 
 

 Locate the ExcelAdvanced folder on drive C 

 Select JumbleSalesStaff 

 
 

 Click OK 

The Query Wizard asks you to select the columns that you want to import into 
the worksheet. 
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To see the column titles: 
 

 Click the + sign next to JumbleSalesStaff 

 Choose FirstName and click the arrow button to transfer the column name to 
the right hand window 

 Repeat with LastName, Department, and StartDate 

 
 

 Click Next 
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This step in the wizard enables you to filter the data to view particular rows. 
 
As you require the names of only those staff who started working at Jumble 
Sales Corporation before 1 January 1985: 
 

 In the Column to filter box select StartDate 

 Use the drop list in the StartDate box to choose is less than 

 Complete the criteria to select the records by typing 1/1/1985 

 
 

 Click Next 

 Use the drop list to choose to sort by LastName 

 
 

 Click Next 
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 Ensure that Return Data to Microsoft Office Excel is selected 

 
 

 Click Finish 

The Import Data dialog box is displayed. 
 

 Ensure that Table is selected as the way to view the data 

 Ensure that cell A1 on the Existing worksheet is selected as the place to put 
the data 

 
 

 Click OK 

The data is imported. 
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By default the imported data is linked to the external source – the 
JumbleSalesStaff workbook – and can be set to update every time the workbook 
is opened. 
 

 Click on any cell within the imported data on the Bonus Payments sheet 

 Click the Refresh down arrow in the External Table Data group on the 
Design Table Tools tab 

 
 

 Select Connection Properties 

The Connection Properties dialog box is displayed. 
 

 In the Refresh control section of the dialog box, select the option to Refresh 
data when opening the file 

 
 

 Click OK 

 Save and close the workbook 



Excel Advanced (021209) 37 ©De Montfort University, IT Training 2009 
 

In order to verify that the data updates when you reopen the workbook, you will 
edit the start date of one of the staff in the source spreadsheet. 
 

 Open the workbook JumbleSalesStaff 

Marie Kaur was not included in the imported list because her start date did not 
meet the criteria used.  You will change her start date and then check that she 
is added to the list of extracted names. 
 

 Edit the StartDate value for Marie Kaur (G14) to be 06/10/1980 

 
 

 Save and close the workbook 

 Open the JumbleSalesPay workbook 

 Look at the Bonus Payments sheet 

Notice that the imported data have been updated to include Marie Kaur. 
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You no longer need the imported data to be updated from the source, so you will 
break the link between them. 
 

 Click on any cell within the imported data on the Bonus Payments sheet 

 Click Unlink in the External Table Data group on the Design Table Tools tab 

A message box warns you that this action is permanent. 
 

 
 

 Click OK 

 Save the workbook 
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THE CONCATENATE FUNCTION 
 
When you are creating a worksheet, you should spend some time thinking about 
how you are going to use the data.  For example, it is always a good idea to 
ensure that first names, last names, and titles are entered in separate cells.  
This makes it easy to sort by last name.  Sometimes, however you may want to 
see the first and last names in the same cell and you can use the Concatenate 
function to join the data in different cells, and also add extra text. 
 
You are going to add a cell to the imported data that reads: 
 
‘Anthony Bare works in the Representatives department.’ 
 

 In cell F2 on the Bonus Payments sheet, type the following: 

=CONCATENATE(A2,“ ”,B2,“ works in the ”,C2,“ department.”) 
 
Notice that text must be surrounded by speech marks – this includes spaces. 
 
Here is an explanation of the function above. 
 

= All functions and formulae must start with the equal sign 

Concatenate The name of the function 

( The text and cell references are enclosed within braces 

A2 The cell that holds the first name 

“ ” A space between the first name and last name – it must be 
within speech marks or Excel will ignore it 

B2 The cell that holds the last name 

“ works in the ” Additional text including spaces within speech marks 

C2 The cell that holds the name of the department 

“ department.” Additional text – notice that a space is included as the first 
character 

) The end of the function 
, Commas separate the cell references from text 
 

 Press the Enter key 

 
 

 Copy the function to the other members of staff on the sheet 
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JOINING CELLS WITHOUT THE CONCATENATE FUNCTION 
 
An alternative method of joining values in different cells is to simply use an 
ampersand as the ‘joining’ character.  For example: 
 
=(A2&“ ”&B2) 
 
The example shows a space within speech marks but you could add extra text 
also if you wanted to.  For example: 
 
=(A3&“ ”&B3&“ works in the ”&C3“ department.”) 
 
There is no need to leave spaces within the command, except where one is 
required in the text. 
 

 Delete the concatenate functions that you created in Column F 

 In F1 type the column label Name 

 In F2, without using the Concatenate function, join the first name and last 
name of the first member of staff on the list 

 Copy the formula to the other members of staff on the sheet 

 Ensure that Column F is wide enough to display the names fully 
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DATA VALIDATION 
 
For this exercise you will use the data validation option in Excel to ensure your 
data is within specific limits. 
 
Staff who have been employed at Jumble Sales Corporation for more than 25 
years will be paid a one-off bonus of 10 times their hourly pay.  However there 
will be a minimum (£50) and a maximum (£100) acceptable payment. 
 

 Ensure that JumbleSalesPay is open and that the Bonus Payments sheet is 
selected 

 In G1 type the column label Bonus 

You are going to add the validation rule to the cells where it will be applied. 
 

 Select the empty cells G2:G8 

 Click Data Validation (not the down arrow) in the Data Tools group on the 
Data tab 

The Data Validation dialog box is displayed. 
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On the Settings tab: 
 

 In the Allow box, use the drop list to choose Decimal 

 In the Data box, use the drop list to choose between 

 Type 50 in the Minimum box (the minimum payment) 

 Type 100 in the Maximum box (the maximum payment) 

 
 

 Select the Input Message tab 
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The message text that you specify here will display as a prompt when one of the 
cells holding the Validation criteria is selected. 
 

 In the Title box type bonus payment 

 In the Input message box type: 

A bonus of 10 times the hourly rate must be paid, but subject to a minimum 
payment of £50 and a maximum payment of £100. 
 

 
 

 Click the Error Alert tab 
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Using this tab, you can type a message that will be displayed if the Validation 
rule is broken. 
 

 In the Title box type: 

Value outside permitted range 
 

 In the Error Message box type: 

Please use the minimum value of £50, or the maximum value of £100 as 
appropriate. 
 

 
 

 Click OK 

Now you will test the Validation rule. 
 

 Format the range G2:G8 as Currency 

 Click into cell G4 

The text that you entered in the Input Message tab is displayed as a prompt. 
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 Type in the formula =10* 

 Select the worksheet for March 

 Select the cell that holds the hourly rate for Jasbir Bonsal (C15) and press 
Enter 

A bonus of £75 is calculated for Jasbir. 
 

 
 

 Click into cell G5 

 Insert a formula to calculate the bonus payment for Michael Burns 

Ten times the hourly rate is £37.50, therefore the following message is 
displayed. 
 

 
 

 Click Cancel 

 Type 50 in G5 for Michael Burns’ bonus 

 Calculate the bonus payments for the other members of staff 

 Save and close the workbook 
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CREATING DROP LISTS 
 
Drop lists make it easier and quicker to enter data into a spreadsheet.  It also 
validates the data entry, ensuring that only the values listed will be accepted. 
 

 Open the Courses workbook 

 Select cell E28 on Sheet1 

You will create a drop list with the two possible venues – Bed and Leics. 
 

 Click Data Validation from the Data Tools group on the Data tab 

On the Settings tab: 
 

 In the Allow box, use the drop list to choose List 

 In the Source box, type Bed, Leics 

 
 

 Click OK 

A drop list button is displayed next to the cell when it is selected. 
 

 Click the drop list button to display the options 
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Next you will create a drop list in cell F28 that takes values from a given range. 
 
To create the options list: 
 

 In the range W1:W4 type the values 1, 2, 3, 4 respectively 

 
 

 Click into cell F28 

 Display the Data Validation dialog box 

 In the Allow box, use the drop list to choose List 

 In the Source box, click the Collapse Dialog button 

 
 

  Select the range W1:W4 

The range is inserted in the Source box using absolute referencing. 
 

 
 

 Click the Expand Dialog button 

 Click OK 

 Check that the drop list displays the values 1 to 4 

It is possible for the list of options to be on a different sheet, but you will have 
to type the appropriate code into the source box because you will not be able to 
use the mouse to select it. 
 
You will use the values in the range A1:A16 on Sheet3 to create a drop list in cell 
D28 on Sheet1. 
 
  

Collapse Dialog  

Expand dialog  
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 Click into cell D28 

 Display the Data Validation dialog box 

 In the Allow box, use the drop list to choose List 

 In the Source box, type: 

=Sheet3!$A$1:$A$16 
 

 Click OK 

 Check the drop list 

Drop lists can be copied to other cells using the usual methods for copying 
values.  For this to work correctly however, cell references must be absolute. 

It is also possible to first select a range of cells and then use the Data Validation 
dialog box to set list options for the selected range. 

 
 Using any of the methods described, create drop lists in G28:G31 on Sheet1 

to display the options: 15, 19.95, 25, 29.95, and 35 

 Clear the drop lists from D28:G31 using the Clear All command in the Editing 
group on the Home tab 

 Save the workbook 
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FORMS 
 
A form is a document designed with a standard structure and format that makes 
it easier to enter, organise, and edit data. 
 
DATA FORMS 
 
A data form is a dialog box that displays one complete record at a time.  
It therefore provides a convenient way to enter or display one complete row of 
data without scrolling horizontally. 
 
You may find that using a data form can make data entry easier than moving 
from column to column when you have more columns of data than can be viewed 
on the screen. 
 
One possible drawback of using a form is that the AutoComplete feature is not 
available, and the user has to type all of the data.  However, a bonus is that 
fields containing calculations are not accessible and, while the results of 
calculations can be seen in the form, the formulas cannot be edited. 
 
Excel can automatically generate a built-in form for your table of data.  The 
Form command, however, is not on the Ribbon and therefore it must be added 
to the Quick Access Toolbar before it can be accessed. 
 

 Click the Office Button 

 Select Excel Options 

 Select Customize from the list of categories on the left 
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 In the Choose commands from: box, click the drop arrow 

 
 
 

 Choose Commands Not in the Ribbon 
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 Select Form from the list of commands 

 
 
 

 Click the Add button 

 Click OK 

The Form command is now on the Quick Access Toolbar 
 
 
 

 
 
 

 Ensure that the Courses workbook is open 

 Select Sheet1 

 Click on any cell within the table of data 

 Click the Form command on the Quick Access Toolbar 

  

Quick Access Toolbar 

Form command 
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A form is created and displays the first record of the table. 
 

 
 
Buttons on the right of the form enable you to navigate and search the data. 
 

 Click Find Next to go to the next record 

 Click New 

A blank form is displayed, ready for you to enter a new record. 
 

 Type the following data in the appropriate fields (you can use the tab key to 
move from one field to the next) 

Sequence Date Course ID Course 
Name 

Venue No 
Sessions 

Cost per 
session 

12815 27/3/01 784 Adv Word Leics 3 £35 
 

 Press Enter 

The new row is added at the bottom of the data in Sheet1, and another blank 
form is displayed. 
 

 Click Find Prev to view the record that you just typed in 

Notice that the three calculations, at the bottom of the form, have been 
automatically performed. 
 

 
 

 Use the scroll bar in the form to scroll to the top, displaying the first record 
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Using a data form to search for specific records 
 
The data form provides a very useful method of searching for information. 
 
You will use the form to search for all the courses named Intro Word. 
 

 Click the Criteria button on the form 

The criteria dialog box is displayed, resembling a blank form. 
 

 Type Intro Word in the Course Name field 

 
 

 Click the Find Next button 

The form displays record number 14, the first Intro Word record. 
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 Click Find Next 

A second Intro Word record is found – record 15. 
 

 Click Find Next 

A third Intro Word record is found – record 16. 
 

 Click Find Next 

No other record satisfies the search criterion, so record 16 remains displayed. 
 
You will now change the search to include a second criteria – You want to find 
all Intro Word courses at Bedford (Bedford is displayed as Bed in the Venue 
field). 
 

 Use the scroll bar to display record 1 in the form 

 Click the Criteria button 

 In the Criteria dialog box, type Bed in the Venue field 

 
 

 Click Find Next 

Record 14 satisfies both criteria and is displayed. 
 

 Click Find Next 

No other record satisfies both criteria, so record 14 remains displayed. 
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 Use the data form to search for the record with Course ID 784 

 With the record with Course ID 784 displayed, click the Delete button 

A message is displayed warning that the action will be permanent. 
 

 
 

 Click OK 

The record is deleted. 
 

 Close the data form 

 Save and close the workbook 
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SHARING WORKBOOKS 
 
Workbooks can be shared by users who have access to the same network.  
Typically a shared workbook will contain data that is regularly updated by a 
group of people, and is stored on a server so that all concerned can gain access. 
 

Features such as merged cells, conditional formats, data validation, charts, 
pictures, drawn objects, hyperlinks, scenarios, outlines, subtotals, PivotTables, 
and macros need to be included in the workbook before it is shared, as these 
types of changes cannot be made to shared workbooks. 

 
 
CREATING A SHARED WORKBOOK 
 
Although during this training session you are not able to share a workbook over a 
network, by completing this exercise you will begin to understand how the 
process works. 
 

 Open the workbook named DecemberSalesFigures from C:\ExcelAdvanced 

 Select Share Workbook from the Changes group on the Review tab 

 Tick the Allow changes box 

 
 
 

 Click the Advanced tab 
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Consider the first three sections of the dialog box: 
 
Track changes 
 
With the Keep change history option selected, Excel will maintain information 
on changes made to the workbook based on elapsed time.  When you share a 
workbook this is switched on automatically so that you can track changes made 
by other users.  You can choose to specify the number of days the history is 
retained, or not to keep the history of the changes. 
 
Update changes 
 
If you are sharing over a network and choose to update the changes made to the 
workbook each time it is saved, then when a user saves the workbook, changes 
made by all the current users sharing the workbook will be saved.  All changes 
will then be available to everyone. 
 
You can choose to have the workbook show you the changes made by others at 
set intervals.  With this option you can specify that Excel saves the changes 
automatically. 
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Conflicting changes between users 
 
You can expect that, when several people are sharing the same workbook, some 
changes will conflict.  This section of the dialog box enables you to specify 
whether you make the final decision on which change will be accepted, or 
whether the latest change is accepted automatically. 
 

 Click OK to close the dialog box 

A message indicates that the workbook will be saved. 
 

 Click OK 

 
PROCESSING CHANGES 
 
Make the following changes to the data: 
 

 Change the contents of cell B5 to 50 

 Change the contents of cell B15 to 16 

Excel automatically tracks the changes made in shared workbooks until the 
changes are either accepted or rejected.  You can therefore highlight the cells 
that have been changed. 
 

 Click Track Changes in the Changes group on the Review tab 

 Select Highlight Changes 

The Highlight Changes dialog box is displayed. 
 
You can choose to highlight all the changes that are currently being tracked, or 
the changes made after a particular date, or the changes made since the file 
was last saved. 
 

 In the When box choose Since I last saved 
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  Click OK 

A coloured border indicates the cells that have been changed.  Each user’s 
changes are highlighted in a different colour. 
 

 
 

 Hover the mouse pointer over cell B5 

A comment is displayed advising the changes that have been made and who 
made them. 
 

 
 

 Move the mouse pointer away from the cell to hide the comment 

When a workbook is shared, someone must take responsibility for the final 
version. 
 
On this occasion consider yourself to be the supervisor who will make the final 
decision on the changes. 
 

 Click Track Changes in the Changes group on the Review tab 

 Select Accept/Reject Changes 

You are reminded that this action will save the workbook. 
 

 Click OK 
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The Select Changes to Accept or Reject dialog box gives you the option to 
choose which changes you would like to review.  You can see either those not 
yet reviewed, or those since a specific date. 
 
You can also select whose changes you review, and which range of cells you are 
going to look at. 
 

 Ensure that Not yet reviewed is selected as the When option 

 Click OK 

The Accept or Reject Changes dialog box is displayed. 
 

 
 
 
The dialog box indicates that two changes have been made, and displays the 
first change.  You can either accept or reject changes individually or as a group. 
 

 Accept the first change (B5) 

 Reject the second change (B15) 

 Save the workbook 
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Merging shared workbooks 
 
Apart from sharing a workbook over a network, another possible use for a shared 
workbook is where you want to email a workbook to colleagues for review.  Once 
they have made changes and emailed their copies back to you, you then need to 
merge the shared workbooks. 
 
Imagine that you have two colleagues who are going to review the figures in a 
workbook.  For the next exercise, you will save a separate copy of the shared 
workbook; make changes to both copies – simulating the work of two colleagues; 
then merge the changes into one document. 
 

 Save the workbook with the new name DecemberSalesFiguresCopy2 

 Make two changes of your own choice to the data 

 Save and close the workbook 

 Open the workbook named DecemberSalesFigures 

 Make two changes of your own choice 

 Save the workbook but do not close it 

You will now merge the two copies of the workbook together. 
 

 Using the Customize Option in the Excel Options dialog box, add the 
Compare and Merge Workbooks command to the Quick Access Toolbar (If 
you need help, see page 49) 

 Click the Compare and Merge Workbooks button on the Quick Access 
Toolbar 

 Select DecemberSalesFiguresCopy2 to merge into the current workbook 

 Click OK 

The workbooks are merged. 
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To see the changes that have been made: 
 

 Click Track Changes in the Changes group on the Review tab 

 Select Highlight Changes 

 In the When box, choose All 

 Click OK 

You should see five changes in all; one from the previous exercise. 
 
Remember that, while the changes you have made are all shown outlined in the 
same colour, changes made by different users will be shown in different colours. 
 

 Review the changes that have not yet been reviewed and accept them all 
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REMOVING A WORKBOOK FROM SHARED USE 
 
When work on the shared workbook has been completed, for security reasons it 
is advisable to remove it from shared use. 
 
Before you do, make sure you tell your fellow collaborators who have been 
working on the workbook over the network that you are taking this action.  If 
anyone is editing the workbook when you remove sharing, they will not be able 
to save any changes they may have made. 
 
When you remove sharing it also cancels track changes and erases the track 
changes history.  Even if the workbook is shared again, the current history will 
have been lost.  Make sure you have finished with the history before sharing 
stops. 
 

 Click Share Workbook in the Changes group on the Review tab 

 On the Editing tab, remove the tick from ‘Allow changes by more than one 
user at the same time’ 

 Click OK 

A warning message is displayed. 
 

 
 
 

 Click Yes to remove the workbook from shared use 
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WORKBOOK SECURITY 
 
It may sometimes be necessary to secure your workbooks to prevent 
unauthorised people from accessing them, or authorised users from making 
changes without agreement. 
 
There are two general types of protection: 
Worksheet protection and Workbook protection. 
 
When you protect a worksheet or workbook, you have the option to include a 
password. 
 
Should you choose to control access with a password, you must keep a note of it 
in a secure place – if you forget the password, you will not be able to open the 
file again. 
 

If you are undertaking the training during a scheduled session in the IT Training 
Room, please do not enter a password to protect a sheet or workbook unless 
specifically instructed to. 
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PROTECTING A WORKSHEET 
 
You would choose to protect a worksheet if you wish to restrict editing of 
formatting, cell content, and objects that may be present on the worksheet. 
 

 Ensure that the DecemberSalesFigures workbook is open 

 Click Protect Sheet in the Changes group on the Review tab 

The Protect Sheet dialog box is displayed. 
 

 
 
The check box at the top of the dialog box is ticked by default and must remain 
ticked in order to protect the sheet and the contents of cells. 
 
In the bottom section of the dialog box you are able to select options you want 
to enable for all users of the worksheet. 
 
By default, users are allowed to select any cell on the sheet, whether locked or 
unlocked – this will be explained in the next section. 
 

 Use the scroll bar in the dialog box to view all of the available options 

The dialog box also enables you to set a password.  If you specify a password, 
this will need to be used if you wish to unprotect and edit the sheet later.  It 
also means that no one else will be able to change your protection settings 
unless you supply them with the password. 
 
For this exercise, do not use a password. 
 

 Click OK 

 Click into a few different cells on the worksheet to verify that you can still 
select any cell 

  



Excel Advanced (021209) 66 ©De Montfort University, IT Training 2009 
 

 Edit the data in one of the cells on the sheet 

A message is displayed, explaining why the data cannot be changed.  However, it 
also includes the steps to take to remove the protection should you want to. 
 

 
 

 Click OK 

To unprotect the sheet: 
 

 Click Unprotect Sheet in the Changes group on the Review tab 

 
Unlocking cells 
 
By default, all cells on a worksheet have the locked property set, but it is only 
when you protect the sheet that it is activated. 
 
When you protect a worksheet however, there may be certain cells on the sheet 
that you do want users to access to enter or edit data.  These cells need to be 
unlocked before the sheet is protected. 
 
Let us assume that you want the users to be able to change the values in the 
Number Ordered column, and you want them to be able to select any of the 
other cells but not make any changes to them. 
 
To set up this level of protection, you need to unlock the cells in the Number 
Ordered column before protecting the sheet. 
 

 Select the cell range B4:B22 

 Click Format in the Cells group on the Home tab 
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The highlighted lock icon next to the Lock Cell option indicates that the cells are 
locked.  This option is used to toggle the lock property on and off.  Notice that 
the Protect Sheet dialog box can also be accessed from here. 
 
To unlock the cells: 
 

 Click Lock Cell 

You will now protect the worksheet as before. 
 

 Click Format from the Cells group on the Home tab 

 Select Protect Sheet 

 Click OK 

 Check that the only changes you can make are to the numbers in column B 

 Unprotect the sheet 
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PROTECTING A WORKBOOK 
 
This works in a similar way to protecting a worksheet.  However, when you 
protect a workbook, you protect the structure and window, but not the data. 
 
To protect the workbook: 
 

 Click Protect Workbook in the Changes group on the Review tab 

 Select Protect Structure and Windows 

 
 
Like the previous exercise, protection will work without a password, but any 
user will be able to remove the protection. 
 
If you choose to protect the Structure, a user will not be able to delete, move, 
hide, unhide, rename or insert new worksheets. 
 
If you choose to protect the Windows, this prevents a workbook’s windows from 
being moved, resized, hidden, unhidden, or closed. 
 

 Click OK 

 Try to delete Sheet2 

You will see that the delete option is not available. 
 
To unprotect the workbook: 
 

 Click Protect Workbook in the Changes group on the Review tab 

 Click Protect Structure and Windows 
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Requiring a password to open a workbook 
 
You can protect a workbook to require a user to have a password(s) to open 
and/or modify it. 
 

 Click the Office Button 

 Click Save As 

The Save As dialog box is displayed. 
 

 Click the Tools button on the dialog box 

 Select General Options 

 
 
Entering a password in Password to open will result in a password being 
required before a user can open the workbook. 
 
If you enter a password in Password to modify, anyone trying to save changes 
using the same filename will be asked for a password. 
 
You are going to set up a password, view the result, and then remove the 
password. 
 
In the Password to open box: 
 

 Type cl3matis 

 Click OK 
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You are asked to verify by typing it again. 
 

 Type the password again 

 Click OK 

 Click Save 

 Click Yes to replace the existing file 

 Close the file 

 Open the file 

 
 

 Enter the password 

 Click OK 

The file opens. 
 

If you set up a password to modify, the user sees a second dialog box. 

 

In this case, the user can either enter the password or, if they do not know it, 
click the Read Only button. 
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To remove the password to open or modify the workbook: 
 

 Click the Office Button 

 Click Save As 

 Click the Tools button on the Save As dialog box 

 Select General Options 

 Delete the password(s) 

 Click OK 

 Click Save 

 Click Yes to replace the existing file 

If you want to change a password, follow the steps to display the General 
Options dialog box.  Enter a new password and resave the workbook. 
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PROTECTING A SHARED WORKBOOK 
 
When sharing work, it is critical that changes can be tracked to ensure the data 
is true.  However, if the workbook is not protected, tracking options can be 
modified or disabled by any user. 
 
To protect the tracking options when sharing a workbook: 
 

 Click Protect and Share Workbook from the Changes group on the Review 
tab 

The Protect Shared Workbook dialog box is displayed. 
 

 
 

 Click Sharing with track changes 

 Click OK 

A message indicates that the workbook will be saved. 
 

 Click OK 

This protection allows some changes to the structure; users can insert, rename, 
or hide sheets, but sheets cannot be deleted. 
 
Also, changes to the data will be tracked and can be highlighted (see page 58). 
 
To unprotect the workbook: 
 

 Click Unprotect Shared Workbook in the Changes group on the Review tab 

This action removes the protection, but the workbook is still shared. 
 

 Remove the workbook from shared use (see page 63) 

 Save and close the workbook 



Excel Advanced (021209) 73 ©De Montfort University, IT Training 2009 
 

PIVOT TABLES AND PIVOT CHARTS 
 
A Pivot Table is an interactive way to summarise large amounts of data.  You can 
use a Pivot Table to analyse numerical data.  You can sort and filter the data, 
and also include totals and subtotals.  A Pivot Table can therefore help you to 
answer unanticipated questions about your data. 
 
CREATING A PIVOT TABLE 
 

 Open the workbook ClubMembership from C:\ExcelAdvanced 

 
 
 
The first step is to identify the data that will be used for the Pivot Table and 
choose where it will be created. 
 

 Click on any cell within the table of data 

 Choose PivotTable from the Tables group on the Insert tab 
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The Create Pivot Table dialog box is displayed. 
 

 
 
The Data Range is picked up automatically and displayed in the dialog box.  At 
this point you can choose a different range, or specify an external data source. 
 

 Check that the Table/Range text box displays ‘Data Sheet’!$A$6:$J$108 

The Pivot Table can be created on a new worksheet or on an existing sheet. 
 

 Ensure that the New Worksheet radio button is selected 

 Click OK 

You are presented with a new worksheet and two contextual tabs (Options and 
Design) appear that include tools to build and edit the Pivot Table. 
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The task pane on the right enables you to select the fields that you want to 
include in the table.  Note that the field names are the column labels in the 
original data table. 
 
The bottom half of the task pane enables you to control where and how the 
fields are displayed in the Pivot report. 
 

 Click the Close button  on the Pivot Table Field List task pane 

To redisplay the task pane: 
 

 Click Field List in the Show/Hide group on the PivotTable Tools Options tab 

The rectangle on the left of the sheet represents the empty Pivot Table. 
 

 Click outside the Pivot Table 

The task pane containing the field list is closed, and the PivotTable Tools 
contextual tabs are removed from the ribbon. 
 

 Click back inside the Pivot Table to redisplay the task pane and the 
contextual tabs 

 Click the Department check box in the Pivot Table Field List 

 
 
When a field that contains text is selected, it is automatically added to the Row 
Labels box in the field layout area of the task pane. 
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The values of the field are displayed in the Pivot Table as Row Labels. 
 

 
 

 Click the Annual Fee check box in the Pivot Table Field List 

When a numerical field is selected, it is automatically put into the Values box.  
By default values are summed, so Sum of Annual Fee is displayed. 
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The Pivot Table displays the Annual Fee values. 
 

 
 

 Click the Type check box to add that field to the report 

The field is added to the Row Labels section below the Department field, and 
the Pivot Table now looks like this: 
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You will change the order of the fields in the Row Labels box to see the effect 
that this has on the report. 
 

 Click the Type field button in the Row Labels box 

 Select Move Up 

 
 
The Type field is moved up above the Department field. 
 

 
 
The groups and subgroups have swapped places in the report: 
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 Click the Type field button in the Row Labels box 

 Select Move to Column Labels 

Alternatively you could drag the field from the Row Labels box to the Column 
Labels box. 

 

 
 
The report provides the same information, but it is now displayed in a manner 
that enables you to compare values more easily. 
 

 
 
You can add as many fields to the Pivot Table as you need. 
 

 Add the Due field to the Row Labels section and move it above the 
Department field 



Excel Advanced (021209) 80 ©De Montfort University, IT Training 2009 
 

 
 
To remove a field from the report you simply remove the tick from the check 
box in the field list section of the task pane. 
 

 Click the Due field check box to remove the tick 

The field is removed from the Pivot Table. 
 
Applying a filter to a Pivot Table 
 
You will set the Due field as a filter field, and use it to change the display in the 
Pivot Table. 
 

 Hover the mouse pointer over the Due field in the Field List and click the 
right mouse button 

 
 

 Select Add to Report Filter 

The Due field is added to the Report Filter box and is also displayed at the top of 
the Pivot Table report. 

Alternatively, to add a field to the Report Filter box you can drag the field from 
the Field List to the Report Filter box. 
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To show only the information for the membership renewals due in April: 
 

 Click the down arrow in cell B1 to see the possible options for the filter 

 Select April 

 
 

 Click OK 

 
  

Report Filter field 
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It is also possible to select multiple values from the filter list. 
 
To view all the memberships due in the second quarter: 
 

 Click the down arrow in B1 

 Click Select Multiple Items to put a tick in the check box 

 Click the check boxes for May and June 

 
 

 Click OK 

 
 
To remove the filter from the values: 
 

 Click the down arrow in B1 

 Select All 

 Click OK 

 Save the workbook 



Excel Advanced (021209) 83 ©De Montfort University, IT Training 2009 
 

The following pivot table was created using the data from the Data Sheet 
worksheet. 
 

 
 

 Select the Data Sheet worksheet and create this Pivot Table report on a new 
worksheet 

Hint: The Due field was used for the row labels, the Type field was used for the 
column labels, the Annual Fee field was used for the values, the Department 
field was used as a report filter and the values filtered to show only the 
information for the Finance department. 
 
 
Changing the Pivot Table value settings 
 
By default, fields that are added to the Values section on the Pivot Table Field 
List layout area are set to sum the data, thus displaying totals in the Pivot 
Table.  You can, however, change the setting so that the Pivot Table displays 
different statistical results, such as a count of the data, or the average. 
 
You will change the values displayed in the Pivot Table on Sheet1 from Sum to 
Count. 
 

 Ensure that Sheet1 is selected 

 Ensure that a cell within the pivot table is selected 

 Click on the Sum of Annual Fee in the Values area 
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 Select Value Field Settings 

 
 
The Value Field Settings dialog box is displayed. 
 

 
 

 Select Count from the Summarize value field by list 

 Click OK 
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 Change the values displayed in the Pivot Table from Count to Average 

 
 
 
Formatting values 
 
To format the values and set the number of decimal places to 2: 
 

 Click on Average of Annual Fee in the Values area 

 Select Value Field Settings 

 Click on Number Format 

The Format Cells dialog box is displayed enabling you to format the values in any 
way you wish. 
 

 Click on Number 

 Ensure Decimal places is set to 2 
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 Click OK to close the Format Cells dialog box 

 Click OK to close the Value Field Settings dialog box 

 
 
 

 Change the formatting of the values to Currency with no decimal places 
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Grouping rows 
 
The values in two or more rows can be combined by grouping to give subtotals. 
 

 Select Sheet2 

The Pivot Table on Sheet2 shows the information for the Finance department. 
 

 Display the information for all departments (see page 82) 

 
 
You will group the information to display the total figures for each quarter. 
 

 Select A5:A7 (January to March) 

 Click Group Selection in the Group group on the Options tab 

 
 
January, February and March are grouped under the heading Group1.  Group 
headings are also created for each of the other months. 
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 Select A9:A14 (April to June) 

 Click Group Selection on the Options tab 

 Select A13:A18 (July to September) 

 Click Group Selection 

 Select A17:A22 (October to December) 

 Click Group Selection 

The data is now split into four groups. 
 

 
 
To include a subtotal for each group: 
 

 Click Subtotals in the Layout group on the Design tab 

 Select Show all Subtotals at Bottom of Group 
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The headings for the groups can be changed to show more meaningful titles. 
 

 Click into A5 (the title for the first group) 

 Type First Quarter and press Enter 

The group title and the label in A9 are changed. 
 

 
 

 Change the other group titles to Second Quarter, Third Quarter, and Fourth 
Quarter 
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To collapse each group and hide the figures for the individual months: 
 

 Click the minus sign next to each group heading 

 
 
To expand each group and display the data for individual months: 
 

 Click the plus sign next to each group heading 
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Grouping numerical or date fields 
 

 Use the data on the Data Sheet worksheet to create a Pivot Table on a new 
sheet, using the Years field as the Row Labels, the Type field as the Column 
Labels, and a Count of Annual Fee for the Values 

 
 
Since the Row Labels in this report are numerical values they can be grouped. 
 

 Click into A5 (any of the Row Labels could be selected for this procedure) 

 Click Group Field from the Group group on the Options tab 

The Grouping dialog box is displayed. 
 

 
 
Excel inserts the smallest and largest values in the appropriate boxes 
automatically. 
 
The By box enables you to indicate how many numbers will be in each group. 
 

 Change the number in the By box to 5 

 Click OK 
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To remove the grouping: 
 

 Click Ungroup in the Group group 

The next exercise is an example on grouping a date field. 
 

 Remove the Years field from the report 

 Add the Joined field to the Row Labels section of the report 

 
 
Each row represents an individual date.  The report would be more usable if the 
dates were grouped. 
 

 Click into A5 (any of the Row Labels could be selected for this procedure) 

 Click Group Field on the Options tab 
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Excel recognises the start and end dates and automatically puts these in the 
appropriate boxes. 
 

 Ensure that Months is the only option selected 

 Click OK 

 
 
To change the date groups to Years: 
 

 Ensure that A5 is selected (any one of the row labels could be used) 

 Click Group Field on the Options tab 
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 Click Months to deselect it 

 Click Years to select it 

 
 

 Click OK 
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Editing labels 
 
The labels and headings in the Pivot Table can be edited without affecting the 
data or headings in the original table. 
 
It is usually more helpful and informative to change the text ‘Row Labels’ and 
‘Column Labels’ to something more meaningful. 
 

 Click into B3 

 Type Type of Membership 

 Press Enter 

 Click into A4 

 Type Year 

 Press Enter 

 Change the width of column B so that the text you typed is fully displayed 

By default, text values are left aligned within the cells, and numerical values are 
right aligned.  This misalignment is most obvious in the Bronze column, but you 
will change the alignment of all the column labels. 
 

 Select the column labels in B4:G4 

 Click the Align Text Right button in the Alignment group on the Home tab 
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Changing design options 
 
Various Pivot Table styles are available to enhance the design of the report. 
 

 Select Sheet2 

 Click the More button on the PivotTable Styles group on the Design tab 

 
 
The full list of styles is displayed. 
 

 Hover the mouse pointer over some of the styles to see the effect on the 
Pivot Table 

 Select Pivot Style Medium 2 from the Medium category 

 
 

 Click on Grand Totals in the Layout group 

 Select On for Columns Only 

 Click on Report Layout in the Layout group 

 Select Show in Tabular Form 

 Click on the checkbox for Banded Columns in the PivotTable Style Options 
group so that a tick appears in the box 

More button 
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 Use the data on the Data Sheet worksheet to create the following Pivot 
Table report on a new worksheet (Hint: the Annual Fee field was used in the 
Values section) 
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CREATING A PIVOT CHART 
 
A Pivot Chart is a graphical representation of a Pivot Table. 
 

 Select Sheet3 

 Ensure that a cell in the Pivot Table is selected 

 Click PivotChart from the Tools group on the Options tab 

 Click on Clustered Cylinder (second row, first column) 

 
 

 Click OK 

A chart is displayed on the worksheet together with a PivotChart Filter Pane. 
 

 Click Move Chart in the Location group on the Design tab 

In the Move Chart dialog box: 
 

 Select New Sheet 

 Change the name from Chart1 to Membership Chart 

Clustered 
Cylinder 
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 Click OK 

 Click the down arrow on the Legend Fields (Series) box in the PivotChart 
Filter Pane 

 
 

 Click on (Select All) to remove all the ticks 

 Click on Gold and Silver 

 
 

 Click OK 
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Changes made to the underlying Pivot Table will be reflected in the Pivot Chart. 
 

It is not necessary to close the PivotChart Filter Pane.  It will be hidden when 
you click on an area outside the chart and reappear when the chart is selected. 

If you do close the Filter Pane, to display it again: 

•  Click PivotChart Filter from the Show/Hide group on the Analyze tab 

 
 Change the Count of Annual Fee to Sum of Annual Fee in the Values section 

of the PivotTable Field List pane 

The chart is changed to reflect the new values. 
 

 
 

 Save and close the ClubMembership workbook 
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FUNCTIONS 
 
This section assumes that you are familiar with functions such as SUM, AVERAGE, 
COUNT and IF, and introduces you to a few more functions that Excel users find 
most useful. 
 
LOOKUP 
 
LOOKUP enables you to find information from a list without having to scroll 
through the list yourself.  It finds a value in one row (or column) of values that 
are stored in ascending order and then returns the value from the same position 
in a different row (or column). 
 
A LOOKUP table can contain two or more rows or columns – in the example that 
follows, the data is in columns.  The first column contains the value you want to 
look up. 
 

 Open a new blank workbook 

 Enter the following data 

 
 

The LOOKUP values (the values in the first column) must be in ascending order  
a-z or 1-10. 

 
 
There are two formats for the syntax of the function. 
 
Let’s say that you need to know the colour that matches number 3. 
 

1. In cell A7, enter the following: 
 

=lookup(3,A1:A5,B1:B5) 
 

In this case the answer is Green. 
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Explanation: 
 
LOOKUP is the name of the function 
3 is the value you want to find 
A1:A5 is the range in which to look for the value ‘3’ 
B1:B5 is the range from which to take the answer to be returned 
 
The value ‘3’ is found in the second row of A1:A5, therefore the value in the 
second row of B1:B5 is returned as the answer. 
 
Using this syntax, you specify the range of cells holding the values you are 
looking up and the range of cells that contain the values for the result.  These 
individual ranges must be single columns (or single rows). 
 
This format is very flexible and could be used even if the two ranges are in 
different areas of the worksheet.  You must remember, however, that the 
ranges must have the same length since the number of LOOKUP values must 
equal the number of possible results. 
 

2. In cell A8, enter the following: 
 

=lookup(3,A1:B5) 
 
The result is again Green. 
 
With this syntax you specify just one range of cells.  Excel will assume that the 
values to look up are in the first column (or row) and that the answers should be 
taken from the last column (or row). 
 

 Edit the formula in A8 to read: 

=lookup(3,A1:C5) 
 
The result is now 45, because the answer is taken from the last column of the 
given range – column C. 
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HLOOKUP AND VLOOKUP 
 
These two functions do a similar job to the LOOKUP function in that they use a 
value that you supply in order to pick out the corresponding value from a given 
range. 
 
VLOOKUP is used when you need to search through a column to find a specific 
value and HLOOKUP when you need to search a row. 
 
As with the LOOKUP function, the column (or row) that contains the lookup list 
must be in alphabetical or numerical order. 
 

 Add the column labels to the worksheet and include the data in column D 

 
 
You want to know the price of item number 6. 
 
You need to lookup the value 6 in column A, so you will use VLOOKUP. 
 

 In cell A10, type the following: 

=vlookup(6,A2:D6,4) 
 
The answer is 67. 
 
Explanation: 
 
VLOOKUP is the name of the function 
6 is the value you are looking up 
A2:D6 is the range containing both the lookup and results columns. 
 The lookup column is always the first column in the range. 
4 indicates that the fourth column in the range holds the results 
 
 

 Amend the formula to find the Cost of item number 2 
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It is also possible to find the price of item number 6 using HLOOKUP. 
 
You will use HLOOKUP to lookup the word Price in the row of column labels.  
First you will change the label in column A to ensure that the column labels are 
in alphabetical order. 
 

 Change the label in A1 to Article No 

 
 

 In cell A11, type the following: 

=hlookup(“price”,A1:D6,5) 
 

The answer is 67 
 
Explanation: 
 
HLOOKUP is the name of the function 
“price” is the value you are looking up. It is enclosed in inverted commas 

because it is text. 
A1:D6 is the range containing the lookup and results rows. 
 The lookup row is always the first row in the range. 
5 specifies that the result is in the fifth row of the range 
 
 
For the next exercise, assume that you work in a shop selling goods from the 
Jumble Sales Corporation.  When you receive an order, the only information you 
have about the product is the Product Number.  A LOOKUP table will be used to 
find the Product Name and the Unit Cost. 
 

 Open the LookupExercise workbook from C:\ExcelAdvanced 

 Ensure that the Products worksheet is selected 
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You need to write a formula in B4 that will pull out the product name for any 
product number entered in cell B2. 
 

 In cell B4, type the following: 

=vlookup(B2,C2:E9,2) 
 
You get the error #N/A since there is not a value in B2 to lookup. 
 

 In B2, enter 3 

B4 displays the name of Product Number 3. 
 

 
 
 
Naming ranges 
 
You are going to name cells so they can be used in the lookup formula.  A named 
area can be a single cell or a range.  Using names rather than cell references can 
be easier when entering functions and formulas into a worksheet. 
 

 Select cell B2 

 Click in the Name Box 
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 Delete the cell reference and type pnumber 

 
 

 Press Enter 

 Select cells C2:E9 and name the range products 

 In cell B5, type the following: 

=vlookup(pnumber,products,3) 
 

 Press Enter 

£2.50 is displayed as the Unit Cost. 
 
How it works: 
 
You named two areas of the worksheet as ‘pnumber’ and ‘products’. 
 
VLOOKUP is the function name 
pnumber is the name of the cell (B2) that holds the value you are looking up 
products is the name of the range of cells (C2:E9) that contains both the 

lookup and results columns 
3 specifies that the result is in the third column of the range 
 

 Type different Product Numbers in B2 and check that the Product Name and 
Unit Cost are displayed correctly each time 

  

Name Box 
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In the next exercise you will create lookup formulas to return the insurance 
value of different vehicles. 
 

 Select the Vehicles worksheet 

 
 

 In C7, use the VLOOKUP function to find the cost of insuring a Van in 
insurance band c (remember that a text lookup value must be encased in 
double quotes.) 

 Edit the function to find the cost of insuring an HGV in band b 

 Select the Insurance worksheet 

 
 
To display the cost of insuring a Van in band c: 
 

 In cell B7, type Van 

 In cell B8, type c 

 Press Enter 

C10 displays the cost of the insurance. 
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 In B7, create a drop list with the options HGV, Motor Car, and Van 

 In B8, create a drop list with the options a, b, c, and d 

 Using the drop lists, display the cost of insuring a Motor Car in band d 

To investigate the formulas on this sheet: 
 

 Click into cell C10 

The formula displayed in the formula bar is =VLOOKUP(B7,A2:E5,G8) 
 
This uses the VLOOKUP function to lookup the value of cell B7 in the first column 
of the range A2:E5.  The formula then looks at G8 to decide which column to 
take the result from. 
 
It will be useful to see what is in G8, but columns G and H are hidden. 
 
To unhide columns G and H: 
 

 Select columns F to I 

 Click Format in the Cells group on the Home tab 

 Move the mouse pointer to Hide & Unhide 

 

 

 

 
 Select Unhide Columns 
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 Now select cell G8 

The formula displayed in the formula bar is =VLOOKUP(B8,G2:H5,2) 
 
This uses the VLOOKUP function to lookup the value of cell B8 in the first column 
of the range G2:H5 and displays the result from the second column of the range. 
 
We noted earlier that the formula in C10 used the value in G8 to decide which 
column in the range A2:E5 it needed to look for the insurance cost.  G8 was 
therefore set up to convert the insurance band codes to a column number. 
 

 Hide columns G and H 

 
Exact match and approximate match 
 
So far, all the values that you looked up were found in the lookup table.  
However, if the value is not in the lookup table, then by default the function 
finds an approximate match.  It takes a smaller value from the table that is 
closest to the value specified. 
 

 Select the Products worksheet 

 Change the Product Numbers in column C to: 1,2,3,4,10,12,19,25 

 
 

 In B2, enter 9 

The Product Number 9 does not exist, so VLOOKUP returns the Product Name 
and Unit Cost for the Product Number 4, which is the value less than 9 that is 
closest to it. 
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This behaviour is very useful in some situations. 
 
For example, if you are converting percentage scores to grades, the lookup table 
only needs to specify the minimum score for each grade. 
 

 Select the Grades worksheet 

 
 
This lookup table will convert to grade ‘U’ any score from zero up to but not 
including 25.  Any score from 25 up to but not including 40 will be converted to 
grade ‘E’, etc. 
 

 In E3, type 40 

 In E4, create a lookup formula to convert the value in E3 to a grade, using 
the lookup table A3:B8 

From the table, the correct grade for 40% is D. 
 

 Change the value in E3 to 78 

78 is not a value in the table, so VLOOKUP goes to the closest value in the table 
that is smaller than 78 and returns a grade of B in E4, which is exactly what you 
wanted. 
 
This default behaviour of VLOOKUP is not always desirable. 
 

 Select the Vehicles tab 

 Edit the formula in C7 to lookup the cost for a Mini Van in band c 

=VLOOKUP(“mini van”,A2:E5,4) 
 
A cost of £80 is displayed even though ‘Mini Van’ is not one of the vehicle types 
in the lookup table.  This is because it looks at the next value that is lower in 
alphabetical order, HGV, and returns the cost for that value.  This can fool you 
into thinking that the table includes the cost for a mini van. 
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In the above situation, to avoid confusion and misinterpretation, it would be 
useful to tell the function to look for an exact match.  This is done by using a 
fourth argument in the function.  This argument can take one of two values: 
TRUE or FALSE. 
 
TRUE has the same effect as omitting the fourth argument (it looks for an 

approximate match) 
FALSE returns an error message if an exact match cannot be found 
 

 In C7, edit the formula as follows: 

=VLOOKUP(“van”,A2:E5,4,FALSE) 
 
The function finds an exact match for ‘van’ and returns the correct cost of £43. 
 

 In C7, edit the formula as follows: 

=VLOOKUP(“mini van”,A2:E5,4,FALSE) 
 
This time the function does not find an exact match for ‘mini van’ and therefore 
displays the error message: #N/A. 
 
This is better than giving an incorrect value, but it is still not ideal.  Later on 
(page 148) you will look at a method for handling this type of error. 
 

 Save and close the LookupExercise workbook 
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PROJECTING VALUES USING PMT AND FV 
 
This section gives you practice in using the PMT (Payment) and FV (Future Value) 
functions. 
 
PMT 
 
Using PMT you can calculate the payments on a loan given that the interest rate 
is stable and the monthly payments are the same throughout the loan period. 
 
For this exercise, we will presume that the directors of Jumble Sales Corporation 
are considering taking a loan to buy new machinery.  However, they are 
concerned about the monthly payments they would be making.  To help them 
decide which loan would be the most suitable, you will work out the repayments 
on £5,000, £10,000 and £15,000 over one, two and three year periods. 
 

 Open the PMTExercise workbook from C:\ExcelAdvanced 

 
 
You will first calculate the repayment on £5,000 over one year. 
 

 Click into cell B5 

 Click Financial in the Function Library group on the Formulas tab 

 Select PMT from the list of Financial functions 
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The Function Arguments dialog box for PMT is displayed. 
 

 
 

 Click in each argument box in turn to see a brief explanation for each one 

For this calculation you need the first three arguments only: 
 
Rate the rate of interest (per payment period) 
Nper the number of payments the loan covers 
Pv the present value (the initial loan entered as a negative figure) 
 
The interest rate shown in D1 is an annual rate.  Since the repayments are 
monthly, the Rate argument must be D1 divided by 12. 
 
The number of monthly repayments (Nper) is the length of the loan in years 
multiplied by 12. 
 

 Enter the arguments as shown below 

 
 

 Click OK 
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So for a loan of £5,000 over one year, the Jumble Sales Corporation will have to 
make 12 monthly payments of £439.58. 
 
To copy this formula to other cells you will need to change the cell references in 
the formula to absolute and mixed references. 
 

 Ensure that B5 is selected 

The formula displayed in the formula bar is =PMT(D1/12,A5*12,-B4) 
 

 Click into the formula bar and make the following changes 

Change D1 to $D$1 (this keeps the reference fixed when the formula is 
copied down or across) 

Change A5 to $A5   (this allows the reference to change when you copy 
 down, but remain fixed when you copy across) 

Change –B4 to –B$4 (this allows the reference to change when you copy 
 across, but not when you copy down) 
 
The formula should now be =PMT($D$1/12,$A5*12,-B$4) 
 

 Copy the formula down to years 2 and 3 

 Copy the formulas across to see all the alternatives for each loan over the 
three years 

The results should be as shown below. 
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FV 
 
After looking at the figures, the directors of the Jumble Sales Corporation decide 
that instead of borrowing the money they will invest £5,000 over one year in a 
savings account that pays them a fixed rate of 5% interest. 
 
They will divide the investment into 12 equal monthly payments and would like 
to know what the future value of this investment will be. 
 

 Using the same workbook, include the additional information shown below 

 
 

 Click into cell B11 

 Display the list of Financial functions from the Function Library group on 
the Formulas tab 

 Select FV 

The Function Arguments dialog box for FV is displayed. 
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The Rate and Nper arguments are the same as the PMT function. 
 
Rate the rate of interest (per payment period) 
Nper the number of payments the investment covers (years multiplied by 12) 
PMT the payment made each period 
 

 Enter the arguments as shown below 

 
 
 

 Click OK 

 
 
 
After one year they can expect the account to hold £5,116.19. 
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 Copy the formula both across and down to see all the alternatives for each 
investment over one to three years 

 
 
 

 Save and close the workbook 
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SUMIFS AND COUNTIFS 
 
SUMIFS 
 
The SUMIFS function is used to sum data in a selected range when specified 
conditions are met. 
 

 Open the ClubMembership workbook from C:\ExcelAdvanced 

 Select the Data Sheet worksheet 

The standard SUM function can be used to calculate the total Annual Fee, but if 
you need to calculate the total Annual Fee for the Maintenance department, or 
the total Annual Fee for the Maintenance staff who joined after 1995, then 
SUMIFS is the function to use. 
 
The syntax for the SUMIFS function is: 
 

=SUMIFS(sum range, criteria range, criteria,...) 
 
Where: 
 
sum range is the range you want to sum 
criteria range is the range where you want to look for a specific condition 
criteria is the value or condition to look for in the criteria range 

Sum range and criteria range must have equal length and shape. 

 
SUMIFS allows you to have multiple criteria range and criteria pairs which 
enables you to sum data that satisfies many different criteria. 
 
For the first example you will calculate the total Annual Fee for the Sales 
department. 
 

 In L3, type Annual fee for the Sales department 

 In L4, enter the following: 

=SUMIFS(i7:i108,g7:g108,“sales”) 
 
The answer is 5031.5 
 
Explanation: 
 
i7:i108 is the sum range (the range of cells to be summed) 
g7:g108 is the criteria range (the range in which to look for the criteria) 
“sales” is the criterion to look for in g7:g108 (non numeric criterion must 

be enclosed within double quotes) 
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Next you will calculate the total Annual Fee for members of the Brokerage 
department who joined after 1995. 
 

 In L6, type Annual Fee for Brokerage staff who joined after 31/12/1995 

 In L7, enter the following: 

=SUMIFS(i7:i108,g7:g108,“brokerage”,d7:d108,“>31/12/1995”) 
 
The answer is 4181.5 
 
Explanation: 
 
i7:i108   the sum range 
g7:g108,“brokerage” first pair of criteria range and criteria 
d7:d108,“>31/12/1995” second pair of criteria range and criteria 
 
The function sums the cells in the sum range for the rows that satisfy both 
conditions. 
 
 
COUNTIFS 
 
The standard functions that are used to count cells in a range are COUNT, 
COUNTA and COUNTBLANK. 
 
COUNT(range)  counts the cells in the range that contain numbers 
COUNTA(range)  counts the non empty cells in the range 
COUNTBLANK(range) counts the empty cells in the range 
 
The COUNTIFS function enables you to count only the cells that satisfy specific 
criteria. 
 
The syntax is: 
 

=COUNTIFS(criteria range, criteria,...) 
 
Where: 
 
criteria range  is a specified range 
criteria is the condition or value that cells in the specified 

range must satisfy in order to be counted 
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The next example shows how to count the number of Gold memberships. 
 

 In L9, type Number of Gold memberships 

 In L10, enter the following: 

=countifs(H7:H108,“gold”) 
 
The number of Gold memberships is 29. 
 
COUNTIFS can take multiple pairs of criteria range and criteria. 
 
To find the number of staff in the Brokerage department with Gold 
memberships: 
 

 In L12, type Number of Gold memberships in Brokerage 

 In L13, enter the following: 

=countifs(H7:H108,“gold”,G7:G108,“brokerage”) 
 
The answer is 6. 
 
The above formula counts the number of rows where gold is present in column H 
AND brokerage is present in column G. 
 

 Save and close the workbook 
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SUMPRODUCT 
 
SumProduct was designed to calculate the sum of the product of two or more 
arrays of numbers. 
 
For example, consider the following data: 
 

 
 
One method for calculating the total cost of all items would be to create a 
fourth column in the table in order to calculate and store the total cost of each 
product and then sum this column. 
 
The SumProduct function can be used to calculate the total cost of the order 
without the need for an additional column. 
 
The syntax for the function is: 
 

=SUMPRODUCT(range 1, range 2, ....) for two or more ranges of equal 
length. 

 
For example:  
 

=SUMPRODUCT(A1:A4,B1:B4) 
 
Will evaluate (A1*B1)+(A2*B2)+(A3*B3)+(A4*B4) 
 

 Open a blank workbook 

 Copy the data from the above table into cells A1:C7 

 In cell C8, enter the formula: 

=SUMPRODUCT(B2:B7,C2:C7) 
 
This calculates (B2*C2)+(B3*C3)+(B4*C4)+(B5*C5)+(B6*C6)+(B7*C7) which is 
precisely the formula needed to calculate the total cost. 
 
The answer is 69.65 
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To verify that this is indeed the correct answer: 
 

 In cell D2, enter: =B2*C2 to calculate the cost of the pork pies 

 Replicate this formula down column D for the other products 

 In D8, use the sum function to add the values in the range D2:D7 

The answer is £69.65, which agrees with the answer using the SumProduct 
function. 
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INDEX AND MATCH 
 
INDEX 
 
The Index function returns the contents of a specified location within a given 
range.  The location is specified by giving the row number and column number 
relative to the top left corner of the range. 
 
The syntax for the function is: 
 

=INDEX(range, row number, column number) 
 
Where: 
 
range identifies the area where the function should look for values 
row number specifies which row in the range to look at 
column number specifies the column to look at 
 
Example: 
 
=INDEX(E7:H12,3,2) will return the value found in the 3rd row and 2nd column of 
the range E7:H12.  i.e. the contents of cell F9. 
 

 
 

 Open a blank worksheet 

 Copy the following data into cells A3:B6 
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 In B8, enter the following formula: 

=INDEX(A3:B6,3,2) 
 
This picks out the value in the third row and second column within the range 
A3:B6, giving an answer of 35. 
 
 
MATCH 
 
The Match function returns the position of a specific value in a given list of 
values.  The values can be listed in a single column range or in a single row. 
 
The syntax for the function is: 
 

=MATCH(value, range, match type) 
 
Where: 
 
value is the value to search for 
range is a one-dimensional range in which to look for a match for value 
match type is the single digit 0, 1 or -1 
 
Three possible values may be used for the match type: 

 0 = Find the first value that is an exact match 
 1 = Use the next lower value if an exact match is not found 

(the range must be in ascending order of size) 
-1 = Use the next higher value if an exact match is not found 

(the range must be in descending order of size 
 
 
Example: 
 
In the list of items that you typed earlier: 
 

 
 
If you needed to find out where ‘Jacket’ was in the list, you could use the 
following formula: 
 

=MATCH(“Jacket”,A3:A6,0) 
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This is equivalent to asking which position in the range A3:A6 has a value exactly 
equal to ‘Jacket’. 
 

 In D2, enter the following formula: 

=MATCH(“Jacket”,A3:A6,0) 
 
The answer is 3, since Jacket is the third item in the list. 
 
 
Combining INDEX and MATCH 
 
When used together, the Index and Match functions become a powerful tool for 
extracting data from a table. 
 
The syntax for the Index function is: 
 

=INDEX(range, row number, column number) 
 
The Match function can be used to calculate the row number value and/or the 
column number value that is needed for the Index function. 
 
For example, given this data: 
 

 
 
To find the cost of the Jacket, you will use the Match function to find out how 
far down the list you need to go to find ‘Jacket’ and then use this in the Index 
function to pick out the appropriate cost. 
 

 In B9, enter the following formula: 

=INDEX(A3:B6,MATCH(“Jacket”,A3:A6,0),2) 
 

• The Match function finds ‘Jacket’ to be the third item in the list 
• The Index function picks out this third item in the second column in the 

specified range A3 to B6 
• The answer given is 35 
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 Enter the following data on the worksheet: 

 
 

 In cell C9, use the Index function with the range B3:D6 to pick out the price 
of a large pair of Jeans 

One possible formula is: 
 

=INDEX(B3:D6,2,3) 
 
since the price of a large pair of Jeans is stored in the second row and third 
column of the specified range B3:D6. 
 

 Now change the formula in C9 so that it will automatically update to give the 
price for whatever item is specified in cell A9  
(Hint: use the Match function to work out in which row the Index function 
should look for the price) 

 Type Pyjamas in cell A9 and check that C9 gives the correct answer 
automatically 

The formula you should now have in C9 is: 
 

=INDEX(B3:D6,MATCH(A9,A3:A6,0),3) 
 

 Now change the formula in C9 so that it will automatically update to give the 
price for whatever size is specified in cell B9  
(Hint: use the Match function to work out in which column the Index function 
should look for the price) 

 Change A9 and B9 to T-Shirt and Small respectively 

 Check that C9 gives the correct answer of 6 

The formula you should now have in C9 is: 
 

=INDEX(B3:D6,MATCH(A9,A3:A6,0),MATCH(B9,B2:D2,0)) 
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 Open the LookupExercise workbook from C:\ExcelAdvanced 

 Select the Insurance worksheet 

 In D10, use the Index and Match functions to calculate the cost of insuring 
the vehicle type specified in B7 and Insurance band specified in B8 

The answer should be the same as C10. 
 

 Save and close the LookupExercise workbook 

 Close any other open workbook without saving 
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WHAT-IF ANALYSIS TOOLS 
 
What-if analysis is carried out to study the variation of the output to changes in 
the input variable. 
  
Tool Description 

 
Goal seek Use this when you know what result you are looking for from a 

formula, but not the value that the formula requires in order to 
calculate the answer. 
 

Data table This is a range of cells that shows how changing one or two 
variables in your formula will affect the results of the formula. 
 
Data tables provide a shortcut for calculating multiple results in 
one operation and a way to view and compare the results of all 
the different variations together on your worksheet. 

 
 
GOAL SEEK 
 

 Open the Analysis workbook from C:\ExcelAdvanced 

 Ensure that the GS example worksheet is selected 

 
 
The formula in B4 uses the FV function to calculate the final amount that will be 
payable to you if you invested £150 monthly for 3 years at a rate of 5%. 
 
However, you need the final amount to be £7,000.  You therefore want to know 
how many years it will take to achieve this amount if the monthly deposit and 
annual rate remain the same. 
 
Goal Seek was designed to provide such an answer. 
 

 Click into B4 (this is the cell that you want to set) 

 Click What-If Analysis from the Data Tools group on the Data tab 
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 Select Goal Seek 

The Goal Seek dialog box is displayed. 
 

 
 
B4 is automatically inserted in the Set cell box. 
 

 In the To value box, type 7000 

To achieve this value, you want Goal Seek to alter the number of years for the 
investment.  This value is stored in B3. 
 

 In the By changing cell box, type B3 

 
 

 Click OK 
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The worksheet displays the new figures. 
 

 
 
You can see from the figures that in just over 3½ years the investment will 
amount to £7,000. 
 
The Goal Seek Status is also displayed.  It shows that it has managed to achieve 
the target that was set. 
 

 
 
We do not want to keep this solution on the worksheet. 
 

 Click Cancel 

Instead, you want to leave the investment period as 3 years and see what 
amount you will need to deposit each month to achieve the £7,000. 
 

 Ensure that B4 is selected 

 Select What-If Analysis on the Data tab 

 Choose Goal Seek 

 Enter 7000 as the value to achieve 

 Enter B1 as the cell to change 

 
 Click OK 
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The figures show that £181 monthly deposit will achieve £7,000 after 3 years. 
 

 Click OK to accept these figures in the worksheet 

 
DATA TABLE 
 

 Select the 1-D table worksheet 

 
 
The formula in B5 uses the values in B1, B2 and B3 to calculate the final amount 
payable to you if you invest £150 each month for 3 years at 5% interest, as in the 
previous example. 
 
This time however, you want to create a table to show the amounts you will 
receive for investments over different time periods. 
 
The Data table tool will do this for you automatically. 
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 Select A5:B12 

Note that this selection includes: 

•  The cell with the formula, B5 

•  The range containing the different values to take for the number of years 

•  A range of blank cells in which to display the answers 

 
 Click What-If Analysis in the Data Tools group on the Data tab 

 Select Data Table 

The Data Table dialog box is displayed. 
 

 
 

 In the Column input cell box, type B3 

This is because in this example, the tool needs to fill in the results down the 
column, changing the value for the number of years, and in the formula, B3 is 
the cell reference for the number of years. 
 

 Click OK 
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This next exercise is an example of how to create a two dimensional Data Table. 
 

 Select the 2-D table sheet 

 
 
The formula in A5 uses the values in B1, B2 and B3 to calculate the amount you 
will receive at the end of the investment. 
 
You will use the Data Table tool to complete the two dimensional table, showing 
the different amounts payable when you vary both the interest rate and the 
duration of the investment. 
 

 Select the range A5:F12 

The range selected must include: 

•  The cell with the formula, A5 

•  The different values to use for the number of years, arranged in a column 

•  The different values to use for the interest rate, arranged in a row 

 
 Click What-If Analysis in the Data Tools group on the Data tab 

 Select Data Table 

 In the Row input cell box, type B2 

 In the Column input cell box, type B3 

 
 

 Click OK 
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The table shows for example, that depositing £150 monthly for 6 years at a rate 
of 2% per annum will yield a final sum of £11,464.58. 
 

 Save and close the Analysis workbook 
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MACROS 
 
A macro is a series of commands that can be triggered by a keyboard shortcut, a 
button on the Quick Access Toolbar, or from the macro dialog box. 
 
If you perform the same tasks on a regular basis you may consider creating a 
macro to automate the process. 
 
In the Office applications, macros are written in Visual Basic for Applications 
(VBA).  But for those who cannot write VBA code, Excel allows you to record a 
series of steps – using keyboard and mouse – that is then converted into VBA. 
 
RECORDING A MACRO 
 
You are going to record two macros: one that will unlock the cells in a selected 
range and another to protect the active worksheet. 
 

 Open a new blank workbook 

When you start the macro recorder, it records every action that you make and 
every instruction that you give, until you stop the recording. 
 

 Click the Record Macro button located at the bottom of the sheet 

 
 
 
The Record Macro dialog box is displayed. 
 

 
 
  

Record Macro button 
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 In the Macro name box type UnlockSelection 

 Click the down arrow in the Store macro in box 

 
 
You have three choices: 
 
 
 
Personal Macro Workbook Stores the macro in a hidden workbook that opens 

automatically every time Excel is launched.  Using 
this option makes the macro always available 
 

New Workbook Stores the macro in a new workbook 
 

This Workbook Stores the macro in the active workbook (the 
workbook you are currently using) 

 
To decide where to store the macro, you need to realise that the macro can be 
used only when the workbook where it is stored is open. 
 

 Select This Workbook 

 In the Description box, type Unlock each cell within the selected range 

 
 
There is also a Shortcut key section on the dialog box.  You will return to this 
later. 
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 Click OK to start the recorder 

The Record Macro button changes to a Stop Recording button.  Everything you do 
from now will be recorded as part of the macro until you stop the recording. 
 

 Click Format in the Cells group on the Home tab 

 Select Lock Cell to unlock the selected cell 

 Click the Stop Recording button 

 
 
 
You will now create the second macro. 
 

 Click the Record Macro button 

 Complete the Record Macro dialog box as illustrated below 

 
 

 Click OK to start the recorder 

 Click Format from the Cells group on the Home tab 

 Select Protect Sheet 

 Ensure that the check box to Protect worksheet and contents of locked 
cells is ticked 

 Ensure also that the options to Select locked cells and Select Unlocked cells 
are ticked 

Stop Recording button 
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 Click OK 

 Stop the recording 

 
RUNNING A MACRO 
 
In order to see the list of available macros, you need to display the Developer 
tab. 
 

 Click the Office Button 

 Click the Excel Options button 
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The Excel Options dialog box is displayed. 
 

 Click on Show Developer tab in the Ribbon to put a tick in the check box 

 
 

 Click OK 

 Click Macros from the Code group on the Developer tab 

The Macro dialog box is displayed and lists the two macros that you recorded. 
 

 
 
You are not ready to run the macros yet. 
 

 Click Cancel 
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 Select Sheet2 

 Type the following in the first four cells of Columns A and B 

 
 
You will now use the macros to unlock the cells in Column B and then protect 
the sheet. 
 

 Select Column B 

 Click Macros in the Code group on the Developer tab 

 Select UnlockSelection from the list of macros 

 
 

 Click Run 

The commands in the macro are executed and the dialog box is closed. 
 

 Run the ProtectWorksheet macro 

If the macros worked correctly, you will be able to select any cell in Sheet2, but 
you can only edit the contents of the cells in Column B. 
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 Click into B1 

 Change the value to 12 

 Click into A3 

 Type your name 

You are not able to type in A3 and a message is displayed, warning you that the 
cell is protected. 
 

 
 

 Click OK to close the warning 

 
Using a shortcut key 
 
The Macro dialog enables you to set a shortcut key, which when pressed will run 
the macro. 
 

 Select Macros from the Code group on the Developer tab 

 Select the UnlockSelection macro and click Options 
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The Macro Options dialog box is displayed. 
 

 
 

 Click into the Shortcut key box 

 Hold down the Shift key and tap U 

The dialog box records the Shortcut key as Ctrl + Shift + U 
 

 Click OK 

 For the ProtectWorksheet macro, set the Shortcut key as Ctrl + Shift + P 

 Click Cancel to close the Macro dialog box 

 Select Sheet3 

 Select the range B2:F4 

 Press Ctrl + Shift + U to run the UnlockSelection macro 

 Press Ctrl + Shift + P to run the ProtectWorksheet macro 

 Check that the macros were run successfully by checking that only the cells 
in the range B2:F4 can be edited 

 With Sheet3 selected, create a macro to unprotect the worksheet (set the 
Shortcut key as Ctrl + Shift + W) 

 Check that your macro works by using the shortcut key on Sheet2 
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Using the Quick Access Toolbar 
 
Your macros can also be launched using Shortcut buttons on the Quick Access 
Toolbar. 
 

 Click the Office Button 

 Click Excel Options 

 Select the Customize category 

 
 
 

 Click the down arrow in the Choose commands from box 

 
 

 Select Macros 
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The list of macros is displayed. 
 

 
 

 Select ProtectWorksheet 

 Click Add 

The macro is added to the list in the right pane. 
 

 
 
All of the macros have got the same icon, therefore it is advisable to change the 
icon for your macro. 
 
To change the icon: 
 

 Ensure that the ProtectWorksheet macro is selected in the right pane 

  Click the Modify button 
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The Modify Button dialog box is displayed. 
 

 
 

 Select any icon from the list (I selected the lock ) 

 Click OK 

The new icon is displayed in the list. 
 

 
 

 Click OK 

The Excel Options dialog box is closed and the macro is displayed on the Quick 
Access Toolbar. 
 

 
 

 Add the UnprotectWorksheet and UnlockSelection macros to the Quick 
Access Toolbar 

 Check that the macros work correctly from the Quick Access Toolbar 
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 Open the LookupExercise workbook (do not close the current workbook) 

 Select Macros from the Code group on the Developer tab 

The macros recorded in the other workbook are listed in the Macro dialog box, 
and are available for you to use in this workbook.  Providing the workbook in 
which a macro is stored is open, it can be used in any other workbook. 
 

 
 
 

 Click Cancel to close the Macro dialog box 

 Select the Insurance tab 

 Select cells B7 and B8 

 Run the UnlockSelection macro 

 Run the ProtectWorksheet macro 

 Check that you can use the worksheet to display different insurance costs by 
changing the values in B7 and B8 but that you are not allowed to change the 
table or the formula in C10 

 Close the LookupExercise workbook without saving 
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SAVING A WORKBOOK WITH A MACRO 
 
The workbook in which your three macros are stored should still be open. 
 

 Click the Save button on the Quick Access Toolbar 

 In the Save As dialog box, change the File name to ExcelAdvancedMacros  
and click Save 

A message is displayed, informing you that your workbook has features that 
cannot be saved in Excel’s standard macro-free workbook format. 
 

 
 
If you click No, the saving process will be cancelled. 
 
If you click Yes, the file will be saved as a macro-free workbook, meaning that 
the macros will not be saved with the workbook. 
 

 Click No 

 In the Save As dialog box, click the down arrow in the Save as type box 

 
 

 Select Excel Macro-Enabled Workbook from the list of file types 

 Click Save 

This workbook is now saved with the macros embedded.  If you wish to use any 
of these macros, then open this workbook and the macros will be available for 
use. 
 

 Close the workbook 
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ERROR HANDLING 
 
Sometimes error indicators are displayed in your spreadsheet even though no 
mistake was made when setting up the sheet.  This can make your spreadsheet 
look rather unprofessional at best. 
 
Usually you can predict instances when these errors will occur.  For example, 
#N/A is displayed when a cell referenced in a formula does not have a value.  
Also, #DIV/0! is displayed when a formula is attempting to divide by zero. 
 
To properly handle most of the errors that can occur, you will need to use the 
Visual Basic for Applications (VBA) programming language to write code for your 
spreadsheet.  However, for those who do not know VBA, Excel has a few built-in 
functions that can help you to manage certain anticipated error indicators. 
 
IFERROR 
 
The IFERROR function can be used to prevent some of these error indicators 
from appearing, and in some cases provide useful information or instruction for 
the user. 
 

 Open the LookupExercise workbook 

 Select the Products tab 

 Delete the value in B2 

B4 and B5 both display the error #N/A. 
 

 
 

 Click into B4 

You know that the formula in B4 will produce the correct answer if a legitimate 
product number is typed in cell B2.  Your aim therefore is to stop the error 
indicator, #N/A, from appearing and replace it with a useful message. 
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The syntax for the IFERROR function is: 
 

=IFERROR(expression, value_if_error) 
 
Where: 
 
expression is your original formula that calculates the value for the cell 
value_if_error is the alternative value that you want displayed in the cell if 

the expression generates an error of any type 
 

 Edit the formula in B4 to read: 

=IFERROR(VLOOKUP(B2,C2:E9,2), “Enter a product number in B2”) 
 

 Ensure that column B is wide enough to display the full text 

 Select B5 

You do not need any additional instruction in this cell, so you will edit the 
formula to display an empty cell if an error occurs. 
 

 Edit the formula in B5 to read: 

=IFERROR(VLOOKUP(pnumber,products,3), “”) 
 
The following display is achieved: 
 

 
 

 Enter a legitimate product number in B2 to check that the original formula 
still works as expected 

The formula in C7 on the Vehicles sheet gives an error message if an exact 
match is not found. 
 

 Edit the formula to display the message “This information is not available” 
if an exact match is not found 

 Save and close the workbook 

 


